iPod Classic
Supported Systems/Models 5th Generation
Number of Players Supported 1 Player
Notes iPod Software 1.2 or later required.


Technical information contributed by Sciere (358769)