Forums > News > Moby v20230223 Release

user avatar

MobyReed (357) on 2/24/2023 5:17 AM · Permalink · Report

v20230223

  • Added groups, genres and attributes to browse menu
  • UI updates for contribution tools: critic scores and release info
  • Better error reporting for image uploads
  • Fixed “the role name is required” bug
  • Fixed moby_html
  • Email service fixes
  • More URL redirects
  • Misc. UI tweaks, fixes
  • Misc. backend optimization, cleanup
user avatar

Vereina (785) on 2/24/2023 2:56 PM · Permalink · Report

Looks like you've changed something in the coding, because in the game browser mode the link up in the URL box became something horrendous. I've used it before to quickly jump to a page number I want to go (page:0 -> page:23) and it worked, but now it's impossible to figure out what to alter so the new link would make that jump.

Any possibility please to add quick page navigation option?

user avatar

Cavalary (11447) on 2/24/2023 6:09 PM · edited · Permalink · Report

Hmm, something changed to points? Seems like there's a different number... And comparing to an archive.org snapshot of my profile that someone apparently made, seem to have lost over 100 points. Yet if I check the contributions, see that just polls have been removed, otherwise the total resulting from that page is still the old one, but what's listed on the main profile page and in the header it's lower.

And still waiting for a return of the contributions per year listing...

Also, old user profile links don't redirect. And any link with a trailing / still doesn't.

Oh, and to me manually editing the page in the browser URL still seems to work at least, even with a bunch of filters. Just make sure you leave the trailing / It won't work if you remove it.

user avatar

Vereina (785) on 2/24/2023 8:03 PM · Permalink · Report

It's actually back to make sense from the horrendous, so yeah, editing the link works again

user avatar

Foxhack (32099) on 2/24/2023 9:24 PM · Permalink · Report

I -still- can't see this post or anything other that you've posted in the news forum list. I don't understand why this is hidden for some reason.

user avatar

gingerbeardman (878) on 2/28/2023 5:52 PM · Permalink · Report

Yup. Thought I was going crazy not being able to see this or more recent posts in news.

user avatar

William Prater (4) on 2/24/2023 11:16 PM · Permalink · Report

The search function seems to have stopped, uh, functioning.

user avatar

Cavalary (11447) on 2/25/2023 1:10 AM · Permalink · Report

Seems to work at the moment. Just as badly though, not listing number of results and being very loose and inexact. For example, with GOG's launch of Vampires Dawn 3 today and knowing the others are freeware, did a search for them here, finding that just two seem to be in the database, but they showed up as 4th and 5th results for a search for Vampires Dawn, after "Vampires!", "Drawn Down" and "Countdown Vampires" (only this one even including both terms, one as part of a word), and said search returned a total of 109 and a half pages of results! And if I put it in quotes, "Vampires Dawn", which should really search for the exact phrase, those two games from the series are indeed finally the top two results, but I still get 107 pages of results, so just weeded out a tiny fraction.

user avatar

William Prater (4) on 2/25/2023 1:22 AM · Permalink · Report

So now the search function is working, but attempting to go to the game browser returns an error that says "The search service is currently unavailable."

user avatar

Kam1Kaz3NL77 (569710) on 2/25/2023 12:00 PM · Permalink · Report

And now it just says nothing, just an empty page with just the header

user avatar

Foxhack (32099) on 2/25/2023 11:38 PM · edited · Permalink · Report

Going to a company page and trying to see their list of games shows an error.

https://www.mobygames.com/company/3638/deck-13-interactive-gmbh/ - Click on "Games", "The search service is currently unavailable".

Edit: And I STILL can't see this post in the main topic list.

user avatar

Kam1Kaz3NL77 (569710) on 2/26/2023 10:36 AM · Permalink · Report

Previous mobygames also showed what kind of contribition they had with game: e.g. dev / pub / graphics. Not showing... Or should that be on the error page?

user avatar

Terok Nor (42297) on 2/26/2023 11:14 AM · Permalink · Report

I believe that was still there a couple of days ago.

user avatar

Kam1Kaz3NL77 (569710) on 2/25/2023 12:10 PM · Permalink · Report

  • On the front page usually i'd could uncollapse the three sections "most researched x" and they would stay uncollapsed, so i could get the "recent games, covers, screenshots" section at the top, without scrolling further down the page and they stayed that way (cookies, right).... now they stay collapsed and scrolling down the page again!.

  • Search/Browse at the top either returns a blank page / error or don't work / search bar gone......

  • Scraped entries through Steam: editting the faulty release date still needs source (why?), but now not even responding -> seems the blue submit button doesn't register all inputs (or their back-end is down)

  • In the beta (which is the previous database, i guess) i see i had three/four things rejected, because i hadn't submitted in time (happened in the site "off-time", no problem, happens) -> the email notification hadn't been on-line at the time, so these were missed/not sent (it happened, no problems) -> but they are still WIP? -> I think all WIP items that have been transferred ar soft-locked and still cannot be editted

user avatar

Kam1Kaz3NL77 (569710) on 2/26/2023 12:20 PM · Permalink · Report

If a submission of mine works to get through (still don't know why 9/10 don't), i'll get a 50/50 chance that it either reverts back to teh main page (yeah, mission complete) OR it lands back on the submission page, with no information as of why. If i THEN press the submit button AGAIN, i'll get the message "This game is not WIP."

Mind you the 9/10 that don't work getting through the submission don't show that..... So.....-> Information if it workedunclear, if it works at all

user avatar

Kam1Kaz3NL77 (569710) on 2/26/2023 1:46 PM · edited · Permalink · Report

Tried to edit a WIP game's title, cause it was missing a few capitals and had a JAP name in it. Asked for source :P -> okay willing to oblige -> then it was suddenly pending WTF -> luckily added all information before then, but still -> could NOT recall it back....

BTW are we Bethesda now? "It's not a bug, it's a feature"

I know i'm coming on strong, with all the nagging lately, you are doing your best, but it takes a lot to get me pissed..... I'm hanging on by a thread of frustration and hope that this will work out!

---- 424 WIP items --- about 200 of them not able to put in pending queue ----> YEAH :(

user avatar

Tracy Poff (2095) on 3/1/2023 4:45 PM · Permalink · Report

Tried to edit a WIP game's title, cause it was missing a few capitals and had a JAP name in it. Asked for source :P -> okay willing to oblige -> then it was suddenly pending WTF -> luckily added all information before then, but still -> could NOT recall it back....

So, you were on the first page of the new game wizard, where you can edit the title, genres, etc., you changed the title, and when you hit the "Continue" button at the bottom of the page, it submitted the game instead of going to the additional info page? That should absolutely not be possible. Please give me a link to the game, and any other details that seem relevant to you.

BTW are we Bethesda now? "It's not a bug, it's a feature"

There are certainly some changes that are just features that work differently, but there are plenty of bugs still to iron out. There's a lot to do and just one of me, but we are getting them worked out, with a few missteps along the way. I'm sorry it's been a little rough at first, but we're trying our best to get everything working for you. Believe me when I say it's as frustrating for me to have released something with bugs like this as it is for you to encounter the bugs.

user avatar

Gopherman on 2/27/2023 10:07 PM · Permalink · Report

This is a step in the right direction, but there's still a lot of super valuable features from the old MobyGames missing. For example, you can no longer browse by platform AND attribute at the same time. For example, if I want to find out how many games for the Apple II were released on cassette tape, I used to be able to browse Apple II and then refine by tech specs\media type. Can't do that anymore. I can browse Apple II games, sure, and I can browse every game in the database that was released on cassette for any platform, but there doesn't seem to be any way for me to refine my browsing in either of those categories. I can't even refine my search results anymore. That's a big loss that makes certain kinds of information (information that used to be easily accessible) simply impossible to find.

user avatar

MobyReed (357) on 3/1/2023 4:38 PM · Permalink · Report

That'll be in the game browser in the not too distant future. In the meantime, attributes can be explored here.

user avatar
user avatar

Tracy Poff (2095) on 3/1/2023 4:28 PM · Permalink · Report

Hm, you mean in the approval comments box? There's a limit, but it's pretty big. Most likely some other check failed. In the next update, we'll have better reporting of those errors.

user avatar

Vereina (785) on 2/28/2023 7:10 PM · Permalink · Report

I'm a bit confused about the pagination in the game browser. Does it have to be 50 points within the last 12 months (up to today), or it has to be 50 points within the previous calendar (say 2022) year?

user avatar

MobyReed (357) on 3/1/2023 4:32 PM · Permalink · Report

It should be over the past 12 months. If that's not working, it's a bug.

user avatar

Tracy Poff (2095) on 3/1/2023 5:06 PM · Permalink · Report

Since the start of the current calendar month a year ago--so at any time in March 2023, it's all the points you've gained since March 1st, 2022. This total updates nightly.